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NCTech iSTAR 360 camera to provide rapid HDR imaging
for FARO Focus 3D point cloud colourisation

The FARO Focus 3D X130 scanner does offer
colour capture but is limited to single exposure,
not HDR. It therefore does not always provide
adequate results in challenging lighting
conditions. NCTech iSTAR cameras can be
used to provide HDR imagery for improved
performance and reduced time on-site. NCTech
ColourCloud technology is integrated within

Faro SCENE from version 6.0 and the NCTech
ColourCloud app can be downloaded free of
charge from FARO 3D App Centre. Using the
ColourCloud app integrated into FARO SCENE
further streamlines user workflow by enabling
automatic point cloud colourisation and import
of iSTAR images without needing to leave the
SCENE workflow environment.
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The aim if this report is to show the workflow used to achieve quality
coloured point cloud using NCTech iSTAR imaging and FARO SCENE 6.0
and its advantages.
01. Software installation
02. Fieldwork
03. Office-work
04. Results
05. Colourisation using iSTAR data against laser scanner internal camera
06. iSTAR data within FARO WebShare
07. Conclusion
08. Acknowledgements

01. Software installation
Installing FARO SCENE
http://www.faro.com/products/faro-software/scene/free-trial
Installing NCTech ColourCloud app:
http://www.faro.com/faro-3d-app-center/scene-plug-in-apps

02. Fieldwork
Working with NCTech solutions is the easiest, most accurate and
highest speed method of colouring point clouds with iSTAR images:
02.01. PLANNING SCAN STATIONS no change to standard process for
scanning with or without colour.

02.04. CAPTURE iSTAR IMAGES by replacing the FARO Focus 3D X130
with the iSTAR¹ camera each scan station, and capture 360 images in
full colour. NCTech supply an adaptor rod for use with the FARO QRS
(Quick Release System) to accurately locate iSTAR at the same central
capture position as the scanner.
Depending on the system used to connect tripod and laser scanner,
NCTech recommend a 40 mm pole to use in combination with scanner
aluminium adaptor and Tribrach connection or a 60 mm adaptor for
FARO quick release system. The 40 mm adaptor rod option was used
in this case although the 60 mm Faro quick release mount is more
advisable for on-site time saving.
iSTAR has different HDR modes enabling single exposure, five
exposure and nine exposure 360 images to be created. Five exposure
HDR imaging (HDR ON) was used here and capture time was typically
10-20s² per scan position in normal lighting, in some very dark areas
this was extended to 75s. iSTAR’s on camera interface is designed to
be very simple to us like a regular automatic digital camera.
Knowledge of photographic techniques is not required with iSTAR,
which automatically calculates the most suitable exposure value
taking into account the entire 360 scene. FARO Focus 3D X130 capture
time including image capture was 12 minutes (medium resolution and
quality scan settings) per scan station.

02.02. SYNCHRONISE LASER SCANNER AND iSTAR TIMES. In order to be
able to use batch processing with automatic scan to image matching,
both time devices must be synchronised due to matching being based
on capture time. Go to the “clock icon” under main settings screen to
set time and date on NCTech iSTAR camera.

Img. 02.02. Adaptor rod (60 mm) quick release mount to achieve the
right position for use with FARO Focus 3D X130.

Img. 02.01. NCTech iSTAR interface where date and time can be set.
02.03. CAPTURING POINT CLOUDS with the FARO Focus 3D, select the
laser scanner resolution you consider most suitable for the job as in
normal use. NCTech solutions work irrespective of scan resolution.
FARO Focus 3D X130 capture time was 12 minutes (medium resolution
and quality scan settings) per scan station and 17 scan stations were
performed.

1 - NCTech recommend using its adaptor poles to accurately locate the camera in the correct
position, different adaptors are used for other laser scanning systems (Leica, Faro, Topcon,
Surphaser, Trimble, Z+F…).

2 - The full iSTAR capture process includes “Analysing time”, “Capturing time” and “Saving time”.
During saving time the “OK to move iSTAR” message will appear on the iSTAR screen, at which
point iSTAR can be moved to the next capture position.. For this reason in this example quoted
capture time doesn’t include “Saving time”.
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03. Office-work
The entire colourisation workflow is fully integrated inside FARO
SCENE 6.0 onwards.
03.01. OPEN SCAN DATA IN FARO SCENE.
To import scan data into FARO SCENE it is first necessary to create
a new project File>New>Project and then you can import the scan
points File>Import. If “Error Code 18” is seen when importing a scan
then first copy your files to hard-disk before you drag and drop into
FARO SCENE.

Img. 03.03. FARO SCENE loaded scan.
03.03. REGISTER SCANS.
To register scans click right mouse button on “Scans” folder and go to
Operations>Registration>Place Scans. Cloud-to-cloud registration will
be automatically launched.

Img. 03.01. Laser scanner raw files when imported into FARO SCENE.
03.02. LOADING SCANS.
To view and to process, the scan has to be ‘Loaded’. Right click on the
corresponding scan>Loaded. When the scan is loaded a green square
icon appears.

Img. 03.04. Cloud-to-cloud registration within FARO SCENE.
When registration process is finished, a “Scan Fit” is created for each
scan station. Scan manager window will pop-up or can be opened
by clicking Scans>Scan Manager>Properties. In the Scan Manager
Window, scan results can be checked.

Img. 03.02. FARO SCENE scan loading process.

Img. 03.05. Registration scan results within FARO SCENE.
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Scans>View>Correspondence View shows the scan results in a visual
interactive view, instead of only seeing the results in a chart results.

Right click on any scan to colourise it, as in other colourisation
processes available at SCENE. An option “NCTech Colourise” is added
after NCTech ColourCloud installation. A pop up window to select the
corresponding *.nctri iSTAR raw data file will appear after clicking on
“NCTech Colourise” option.
Import data and colourisation process will be done fully automatically
at once. “Abort” option is also available during processing.

Img. 03.06. Registration scan results within FARO SCENE
Correspondence View.
After finishing a cluster registration or the general registration the
Scan Manager can be locked (Scan manager right click> Lock All) so
that the relative position of scans each other will not be changed any
more.
To check the register options go to Tools>Options…, an emergent
window will open, go to Matching>Place scans settings to select the
corresponding “placement mode” (Target Based, Cloud-to-Cloud or
Top View Based) and other settings related with scan placement.
Two interfaces are available in FARO SCENE 6.0. The aforementioned
instructions were based on the ‘old’ interface since the new
interface is designed to lead the user through the common workflow
operations. The user can easily switch between both interfaces.
Img. 03.09. NCTech Colourise option added after NCTech ColourCloud
App installation.

Img. 03.10. “Abort” option available during “Import and Colourisation”
NCTech dialog.
Img. 03.07. FARO SCENE 6.0 new interface.
03.04. NCTECH COLOURCLOUD APP FOR iSTAR DATA COLOURISATION.
NCTech ColourCloud app for ColourCloud integration within FARO
SCENE, from version 6.0. The app is available free of charge from
FARO 3D App Center (http://www.faro.com/faro-3d-app-center/sceneplug-in-apps). It can be installed directly by running the *.fpp file
(FARO SCENE app file format) or from FARO SCENE App Manager.
Once installed, NCTech ColourCloud App icon will appear in the
SCENE interface. Each user may use the SCENE interface they prefer
since the NCTech ColourCloud app works within both. NCTech Colour
settings can be checked by clicking on the app icon.

Img. 03.08. NCTech ColourCloud App icon in FARO SCENE 6.0 interfaces.

Img. 03.11. FARO SCENE“Planar view” corresponding to the scan
station_000 before and after NCTech point cloud colurisation.
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Batch process can be launched by right clicking the “Scans” folder
and select “NCTech colourise” option. Then, select the folder which
contains all the iSTAR files and press “OK”.

04. Results
Coloured point clouds are obtained following described workflow. 17
Scan and iSTAR stations were used to obtain a merged coloured point
cloud of Sta. María de Azogue’s Church.

Img. 03.12. NCTech batch colourisation launching.

Img. 04.01. FARO SCENE“3D view” of registered colourised scans.

Img. 03.13. NCTech image match failure window.
NCTech batch colourisation process will be performed fully
automatically with no need of user intervention. In the case where
a scan can not be matched with an iSTAR image, the user receives a
warning so he can select whether to continue or manually check the
data before launch of the NCTech batch colourisation process. When
the process is finished a pop up “Finished” window will appear.

Img. 03.14. Colourisation finished window.
To launch single scan NCTech colourisation or batch process within
the new FARO SCENE 6.0 interface, select the scan (for single scan
colourisation) or the “Scans” folder (Batch process) and select
“Colourise Scans”. Then, select the corresponding iSTAR*.nctri raw file
(single scan colourisation) or the iSTAR folder (batch process) in the
same way explained for the previous SCENE interface.

Img. 03.15. Launch NCTech colourisation process within new FARO
SCENE 6.0 interface.

Img. 04.02. FARO SCENE“3D View” corresponding to the scan
station_000 after NCTech point cloud colourisation. Indoor general view.

Img. 04.03. FARO SCENE“3D View” corresponding to the scan station_006
after NCTech point cloud colourisation. Indoor apse general view.
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Img. 04.04. FARO SCENE“3D view”. Coloured point cloud corresponding
to scan station_006. Furniture detail.

Img. 05.01. FARO SCENE“3D view”. Grey point cloud corresponding to
scan station_004 before colourisation. Indoor apse.

Img. 04.05. FARO SCENE“3D view”. Coloured point cloud corresponding
to scan station_019. Saint detail.

05. Colourisation using iSTAR data
compared to using internal laser
scanner camera

Img. 05.02. FARO SCENE“3D view”. Coloured point cloud corresponding
to scan station_004. Internal camera colourisation.

As previously noted, FARO Focus 3D internal camera doesn’t provide
HDR imaging capability. The results obtained using NCTech iSTAR
external camera are compared here to the FARO FOCUS X130 internal
camera.
Generally speaking, when using the FARO FOCUS X130 internal camera
for colour capture, the overall capture operation time increases
by around 2 minutes (120 s) on average in order to obtain single
exposure colour image results.
In comparison, NCTech iSTAR captures five exposure HDR images in
approximately 10-20s for most normal lighting conditions, and up to
75s in this example where light levels were very low. In other words,
iSTAR takes less time to capture and produces better colour quality
results.
Difference in colour quality becomes more apparent in high contrast
and low light environments, where HDR capabilities are needed, as in
the interior of the Romanesque church presented in this Application
Note.
Colour comparison is shown inside FARO SCENE 6.0 and 3rd party
software in order to maintain the colour comparison independent
from software performance (Img. 05.04. and Img.05.05.).

Img. 05.03. FARO SCENE“3D view”. Coloured point cloud corresponding
to scan station_004. NCTech iSTAR colourisation.
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Img. 05.04. Scan section corresponding to the scan station_004 after laser scanner FARO FOCUS X130 internal camera colourisation.
3rd party software.

Img. 05.05. Scan section corresponding to the scan station_004 after iSTAR colourisation by using NCTech ColourCloud App for FARO SCENE 6.0.
3rd party software.
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Note that while capturing colour data by using laser scanner internal
camera it was quite frequent to receive the following message from
FARO Focus X130 due to low light conditions:

Img. 05.06. FARO Focus 3D X130 interface. Warning given when colour
capturing with laser scanner internal camera in low light conditions.
Laser scanner set to Spanish. Translation from Spanish to English:
“1650: Environment light too low”

Img. 06.03. WebShare Cloud Export window. Common for both FARO
SCENE 6.0 interfaces.
After the WebShare data is created it can be transferred (WebShare2Go)
or uploaded to the cloud (WebShare Cloud).

“It is possible the scanner is not able to determine the correct camera
configuration and image quality could be affected. The environment
light could be too low or the exposure measurement mode may not
be appropriate for the currently light conditions…”
Img. 06.04. WebShare Data transfer within original FARO SCENE 6.0
interface.

06. iSTAR data within FARO WebShare
Once NCTech iSTAR colourisation has been applied within FARO SCENE,
the workflow to publish your project to WebShare does not differ from
when using the laser scanner internal images:
Whether using WebShare Cloud or Webshare2Go, the first step is to
create “WebShare Data”.

Img. 06.05. WebShare Data transfer within new FARO SCENE 6.0
interface.

Img. 06.01. WebShare Data creation within original FARO SCENE 6.0
interface.

Img. 06.06. WebShare Data upload within original FARO SCENE 6.0
interface.

Img. 06.02. WebShare Data creation within new FARO SCENE 6.0
interface.

Img. 06.07. WebShare Data upload within new FARO SCENE 6.0
interface.
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Although WebShare Cloud offers more functionality than WebShare2Go,
there is no difference from a visualisation viewpoint so WebShare2Go
was used in this case. Click at *.bat file to open the project.

Img. 06.11. WebShare2Go viewer. Panorama Image Resolution settings.
Img. 06.08. WebShare2Go viewer. Overview map.

For further information about FARO WebShare Cloud visit
www.faro.com/products/faro-software/scene-webshare-cloud/
overview or www.faro.com/faro-3d-app-center/scene-plug-in-apps/
scene-webshare-2-go for WebShare2Go.

07. Conclusion
Img. 06.09. WebShare2Go viewer. Scan station 019.
Note there are four options for panorama resolution display: ‘Low’
(0.52MP), ‘Medium’ (2.1MP), ‘High’ (8.4MP) corresponding to ‘Standard’
size, and ‘Very High’ (34 MP) corresponding to HD in the WebShare
Data creation dialog.
The Panorama image view in WebShare corresponds to the Planar
View within FARO SCENE, and therefore the maximum resolution
exported during WebShare Data creation depends on the scanner
point cloud resolution and WebShare Cloud Export Data settings.
Thus, the resolution of the images exported to WebShare may be less
than those of standard iSTAR images. However, note that the benefits
of iSTAR HDR still remain despite a deduced resolution, and the 360
environment is displayed with correct exposure.

Coloured point clouds can be obtained through using iSTAR for image
capture, then following the NCTech ColourCloud colourisation process,
fully integrated within FARO SCENE 6.0 as described here.
In the case described in this Application Note the importance and
benefit of HDR capabilities in low light and high contrast environments
can be clearly observed. Furthermore, working with NCTech solutions
combined with the FARO Focus 3D X130 Laser Scanner for point cloud
colourisation is advantageous to alternative techniques for a number
of reasons:
Only one iSTAR shot is needed to colour the entire scene at each
view instead of multiple shots and images per position. This means
less time capturing on site and also eliminates patchy colourisation
experienced where individual images are optimised for their
unidirectional view, then combined.
Knowledge of photography techniques is not needed since iSTAR
analyses the whole scene to calculate the most suitable camera
settings for the full 360 view.
Simple use, minimal training. iSTAR and NCTech software are
designed to be highly automated and user friendly, with minimal
training required.
NCTech ColourCloud App free of charge. NCTech ColourCloud
technology is fully integrated within FARO SCENE from version 6.0 and
the corresponding App can be obtained from FARO 3D App Centre free
of charge www.faro.com/faro-3d-app-center/scene-plug-in-apps
Automatic overlay of iSTAR images to point clouds, avoiding
requirement to manually define common points, eliminating user
error and enabling batch processing for efficient operation.

Img. 06.10. WebShare2Go viewer. Scan View settings.

High performance output in difficult lighting conditions. iSTAR
can provide high visual quality images in a wide range of lighting
environments as a result of the automatic HDR settings and EV range
up to 27 f-stops.

NCTech Ltd 1 Boroughloch Square, Edinburgh, EH8 9NJ, UK
T: +44 131 202 6258 - www.nctechimaging.com

44

Reduced fieldwork data capture time. iSTAR can provide high visual
quality images (HDR ON: 5 exposures, HDR PRO: 9 exposures), often
in significantly less time compared to the laser scanner internal
camera. The HDR imaging process with iSTAR typically takes 1.50’ to
fully complete (including data save during which time the camera can
be moved), depending on lighting conditions. In good to moderately
low lighting this will break down to: 4s Analysing + 7s Capturing +
1.39’ Saving = 1.50’ total. In HDR Pro mode for maximum 9 exposure
dynamic range in very low light this may be 4.50’ total: 1.40’ Analysing
+ 1.20’ Capturing + 1.90’ Saving. Furthermore, visual quality results are
significantly improved.
Automatic batch process. NCTech ColourCloud offers fully automatic
batch process colourisation process with no need for operator manual
intervention, office work time is therefore reduced and an entire
project can be automatically coloured in just one click.
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For further information about iSTAR or NCTech software visit
www.nctechimaging.com or contact us sales@nctechimaging.com

Improved quality of coloured point clouds. iSTAR data produces
improved visual quality compared to the laser scanner internal
camera. Further improvements are gained through additional features
such as “interpolate and fill occluded areas”, automatically applied
in FARO SCENE 6.0 onwards using NCTech ColourCloud App and other
NCTech ColourCloud options.
Fully integrated workflow. NCTech ColourCloud technology is
integrated within FARO SCENE from version 6.0 onwards within
NCTech ColourCloud App (free of charge) and therefore, the user
benefits from a workflow within his ususal point cloud software with
no need to learn new software or change his workflow. In addition,
benefits from using iSTAR data extends to FARO WebShare where data
can be used within the same way as internal laser scanner images.
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